Symptom
- An error occurs when running the scheduled job "Update Compensation Forms for Template" from the UI.
- The job often fails after the job is edited (for example, when adding or updating groups).
- Error message: "Error occurred. org.json.JSONException: JSONObject["username"] not found."
Environment
- SAP SuccessFactors HCM Suite
- SAP SuccessFactors Compensation
Reproducing the Issue
- Sign in and navigate to Scheduled Job Manager.
- Select the job type "Update Compensation Forms for Template".
- Create the job and run it (it may succeed initially).
- Edit the same job (for example, change the name or add/update a group of employees).
- Run the job again and observe the failure with the stated error.
Cause
- UI limitation when editing existing "Update Compensation Forms for Template" jobs, especially after any edit; this leads to missing username context and the reported JSON error.
Resolution
- Workaround in UI: Create a new Job.
- Alternative workaround: Create or modify the job using Provisioning instead of the UI.
The permanent solution of this issue is currently under investigation. Please follow this KBA for updates.
2171560- How to mark a KBA or SAP Note as a favorite and get notified when it is updated - SAP for Me https://me.sap.com/notes/2171560
Keywords
update Job, compensation forms for template, scheduled job, ui job failure, error occurred, head of compensation planning, edit job fails, add group, groups update, scheduled job manager, provisioning, workaround, ui limitation , KBA , LOD-SF-CMP-FRM , Forms & Templates , Known Error
Product
SAP SuccessFactors Compensation all versions ; SAP SuccessFactors HCM Suite all versions
SAP Knowledge Base Article - Public