Symptom
When creating a Quote, CPQ Log is showing “Pricing error: Mandatory condition <Condition Type> <Condition Code> is missing and/or CPQ log may also show: “Mandatory condition <Condition Code> is missing.”, causing pricing to not be properly fetched from S/4HANA
Environment
SAP SALES CLOUD Integrated with SAP Variant Configuration
Reproducing the Issue
- Create a Quote
- Add any VC Item
- Observe that no price is returned and the CPQ log reports the missing condition error.
Cause
Pricing not properly configured.
Resolution
- Verify that condition records for the missing condition are properly maintained and valid in the source S/4 system for the relevant pricing procedure and data combination (for example, customer/material/sales area)
- Review the pricing procedure to confirm whether the condition type must be mandatory. If condition is intended to be optional, remove the mandatory flag in S/4 and re-import the customization as needed
- Check the CPQ-to-pricing integration context (In CPQ Setup, verify the Pricing Determination in Pricing Procedure): ensure all attributes required by the S/4 pricing procedure and user exits for determination are sent in the pricing context
- Ensure middleware synchronization so that pricing data is up to date
- Run a pricing trace in the Variant Configuration and Pricing service to identify why condition is not determined
- If custom logic in pricing procedures/user exits is involved and internal expertise is limited, involve a pricing expert/consulting to review and correct the custom logic.
See Also
Keywords
mandatory condition missing, pricing error, list price missing, cpq pricing, s/4hana pricing, pricing procedure, user exits, pricing context, c4c to cpq quote, no price returned, variant configuration and pricing, CPQ , KBA , CEC-SAL-CPQ , Sales Cloud CPQ , Bug Filed
SAP Knowledge Base Article - Public