SAP Knowledge Base Article - Public

3742220 - Activation Error due to MD_PRODUCT_TYPE 019 "The specified external number range does not exist"

Symptom

Error "Your workspace is locked due to an activation error." at Deploy Scope and Organizational Structure activity.

Environment

SAP S/4HANA Cloud Public Edition

Cause

The issue may be happening due to the configuration done in Number range 02 for MATERIALNR object.
The number range 02 for MATERIALNR cannot be set as an internal number range. As specified in Restrictions in Using Number Range 02 for MATERIALNR | SAP Help Portal:

"Master data eCATTs/Class for MM01 runs into activation errors due to change in the configuration of number range.
Due to this reason, the configuration of number range 02 for MATERIALNR using configuration step has been disabled in the quality system."

Resolution

Make sure number range 02 is set as external in both source and target system by doing the following for each system:

  1. Access SSCUI/Configuration Activity 102282 "Define Number Ranges for Each Material Type"
  2. Click on Edit Intervals (Pencil icon)
  3. Change the Number Range status to 0. 
  4. Set number range 02 to External by checking the checkbox under the External column (with default range of A-ZZZZZZZ or similar)
  5. Click on Save
  6. Reactivate the Activation Request.

To Reactivate the Activation Request after the configuration was saved in the system, do the following:

  1. Access Display Business Configuration Staging app
  2. Select the staging ID with error message
  3. Access for Activation Requests tab
  4. Select the Activation Request
  5. Reactivate the request.

Keywords

MD_PRODUCT_TYPE 19, Product Master, Deployment, Central Business Configuration (CBC), Workspace Locked, Deploy Scope, Material Type, Number Range. , KBA , LO-MD-MM-CNT , Content for Material Master , Problem

Product

SAP S/4HANA Cloud Public Edition all versions