Symptom
When creating a report for Emergency Contact, you observed that two fields: "Last Modified On" and "Created On" have the same value.
The expectation is that after performing a change in the name field, the "Created On" represents the original creation timestamp of the record and the "Last Modified On" represents the performed change. However, the "Created On" date is also being overwritten with the new change date.
Environment
SAP SuccessFactors Employee Central
Reproducing the Issue
- Navigate to a user's profile.
- Open the Emergency Contact portlet and select Edit.
- Change a name of an emergency contact and save.
- Go to Report Center and run Single Domain > Person and Employment audit.
- Select columns such as action type, Created On, and Last Modified On (you can filter the results by user id)
- Observe that after performing the name change in Emergency Contact, the 'Created On' and 'Last Modified On' displayed the same date and time.
Cause
This is an expected behavior.
The Emergency Contact is not effective-dated and editing a key field field (for example: name field) erases the previous record and creates a new one (resulting in both delete and insert operation).
Resolution
This is expected behavior due to the non–effective-dated design and business key usage in Emergency Contact.
If different reporting behavior is desired, submit an enhancement idea: refer to the article in the See also section.
See Also
SAP Guide: Business Keys | SAP Help Portal
KBA: 2090228 - How to submit enhancement ideas for SAP SuccessFactors Products
Keywords
emergency contact, audit report, person and employment audit, emergency contact, created on, last modified on, timestamps, business key, delete insert, non effective dated, person and employment export, report center, audit, action type, employee central, odata, integration, data change , KBA , LOD-SF-EC-PER-PRS , Personal Info - Config, Rules, RBP, UI , Problem
SAP Knowledge Base Article - Public