Symptom
- Administrator is unable to enter user IDs for employees during user creation via the Manage Users tool.
- The system automatically assigns the default username as the user ID for all newly created users.
- UserID column is missing in Manage users tool
Environment
SAP SuccessFactors HCM Suite
Reproducing the Issue
- Access the instance
- Create employees via the Manage Users tool
- Notice that the system automatically assigns the default username as the user ID for all newly created users
- Attempt to manually enter user IDs while creating users via the tool
- Observe that User ID column is missing in the tool
Cause
Show User ID field in Manage Users is disabled in Provisioning
Resolution
- In Provisioning, navigate to Company Settings and enable the option “Show User ID field in Manage Users”.
- In Manage Business Configuration, ensure the “UserID” field is enabled so it can be displayed and edited in Manage Users and relevant permission can be granted to the users.
- Verify that the User ID field is now visible in Manage Users and that administrators can manually enter the correct user ID when creating users.
See Also
Keywords
manage users, user id field, username used as user id, cannot enter user id, user id missing, default username, provisioning setting, company settings, show user id field, user directory, create user, employee import, field visibility, SuccessFactors platform, user management, non EC instance, SAP SuccessFactors HCM Suite, Show User ID field in Manage Users , KBA , LOD-SF-PLT-MNG , Manage user Issues , How To
Product
SAP SuccessFactors HCM Suite 2511
SAP Knowledge Base Article - Public