SAP Knowledge Base Article - Public

3743595 - PGP Key Management Access Fails with System Error in Security Center and Scheduled Job Manager

Symptom

  • An error occurs when accessing PGP Key Management from security center and Scheduled Job Manager.
  • Error message: "There is a system error. Please refresh the page and try again later. If the problem is not solved, contact to system administrator."

"Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental." 

Environment

SAP SuccessFactors HCM Suite

Reproducing the Issue

1. Login to instance
2. Go to Security Center > PGP Key Management, and the error message appears.
3. Go to Scheduled Job Manager > Create Job and select PGP, the same error message appears.

Cause

The issue happens because of invalid PGP key detected, where the key type for the PGP key is neither RSA nor DSA.

Resolution

Engineer team has fixed the issue in on 5th May to enable the page display the PGP key, end user should delete the invalid ones when it gets displayed.

See Also

Keywords

KI1H2026, SFPLS-45108, SuccessFactors, Platform, system error, PGP Key Management, Security Center, Scheduled Job Manager, release, 1H 2026, fix, patch
, KBA , LOD-SF-PLT-PGP , PGP Key Generation , Known Error

Product

SAP SuccessFactors HCM Suite 2605