SAP Knowledge Base Article - Public

3743607 - Case Status is NOT Updated by Determination of Last Customer Interaction On

Symptom

A Case Status is not updated by the determination of "Last Customer Interaction On" even though the determination is set up, and an e-mail is sent to a case.

Environment

SAP Service Cloud Version 2

Reproducing the Issue

  1. Select the System Settings in the User Menu
  2. In the All Settings, search for Extensibility Administration
  3. Open it
  4. Select Case
  5. Select the Determinations tab
  6. Create a determination which updates Case Status by Last Customer Interaction On

Example

Condition Block 1

Is Changed

timePoints/lastCustomerInteractionOn (Last Customer Interaction On)

Equals

True

Summary

If ( timePoints/lastCustomerInteractionOn Is not equal to timePoints/lastCustomerInteractionOn )

 

Assignment Block 1

{status} = ( '02-In Process' )

      7. An e-mail is sent to a case (e.g. Case Status is open)

Result: The Case Status remains open

Expected Result: The Case Status is updated to "In Process".

Cause

Determinations are processed in sequential phases. The timePoints/lastCustomerInteractionOn field is updated after the Pre Hook phases complete, so a Pre Hook condition is not satisfied at that time. This is an expected system behavior.

Resolution

To use an Autoflow.

See Also

KBA 3685029 - Using Autoflow To Update Field In SAP Sales/Service Cloud

Keywords

determination, case status, update, lastCustomerInteractionOn, timePoints/lastCustomerInteractionOn, e-mail, email, incoming, inbound , KBA , CEC-CRM-CAS , Case Management for SAP Sales/Service Cloud , CEC-CRM-CZM-EXT , Extensibility for SAP Sales/Service Cloud , How To

Product

SAP Service Cloud Version 2 all versions