SAP Knowledge Base Article - Public

3744281 - Attachment In Cases Cannot Be Directly Requested Via API In SAP Service Cloud V2

Symptom

Where are the attachments for cases stored, and how can they be accessed?

Environment

SAP Service Cloud

Cause

The attachments for cases are not stored directly inside the Case object. Instead they are stored in the Document Service.

Resolution

- Attachments linked to a case instance can be fetched from the API response of case getById - /sap/c4c/api/v1/case-service/cases/{id}
- API response JSON will have 'attachments' attribute which will have all the attachments linked to the case instance.
- You can use document service endpoints below to view/download the document using the attachment IDs from case API response.

GET /sap/c4c/api/v1/document-service/documents/{documentId}
GET /sap/c4c/api/v1/document-service/documents/{documentId}/download

Keywords

Documents, Attachments, Case, Cases, API, Fetch, Retrieve, Download, Link, URL , KBA , CEC-CRM-DOS , Document Service for SAP Sales/Service Cloud , Problem

Product

SAP Sales Cloud and SAP Service Cloud Version 2 1.0