Symptom
- New hires are not visible in Onboarding dashboard
- Error in BPE after initiating onboarding from RCM
- Error in BPE: "Business key - country - has invalid value: for entity nationalIdCard for userSysId:*"
Environment
SAP SuccessFactors Onboarding, SAP SuccessFactors Recruiting
Reproducing the Issue
- Initiate Onboarding from RCMNavigate to To-Do.Select the Business Process error
- Observe error received in BPE:
ErrorMessage = An error occurred while saving the HRIS data for the user “” due to the following reason: {"responsePayload":[{"userSysId":"","hrisSaveStatus":[{"elementType":null,"key":null,"statusCode":"ERROR","errorInfo":"Business key - country - has invalid value: for entity nationalIdCard for userSysId:*"}]}]}
Cause
- This is caused by a configuration mismatch:
- In the Recruit to Hire Data Mapping tool (under nationalIdCard), the country field is configured to use the country code (“countrycode”).
- In the Suite Integration Mapping tool, the same field is being sent as the full country name, not the country code.
Resolution
- Open the Onboarding “Recruit to Hire Data Mapping” tool.
- Check how the NationalId → country field is mapped.
- Open the Suite Integration Mapping tool.
- We can use Suite Integration Test Tool to fetch what data was passed from RCM -> ONB
Please refer the KBA: 3579652 - An application error occurs while extracting data from the Suite Integration Tool. - SAP for Me
See Also
Keywords
business key, invalid value, nationalIdCard, bpe error, onboarding, error, country, mapping, code, recruiting to onboarding mapping, suite integration mapping, invalid country value, to-do , KBA , LOD-SF-OBX-RCM , Initiate onboarding from RCM , Problem
Product
SAP SuccessFactors Onboarding all versions
SAP Knowledge Base Article - Public