Symptom
Workflow escalation didn’t occur for some employees, even though the escalation feature has been configured in the workflow. In one case, escalation happened only for one approver in the workflow group, not for all the three approvers, and the workflow wasn’t escalated to the expected approver.
Environment
SAP SuccessFactors Employee Central
Reproducing the Issue
1. Configure workflow escalation to escalate to the manager of the current approver.
2. Configure a workflow step with 3 approvers in dynamic group, and the manager of two approvers is the same third approver in the group.
3. Trigger workflow to the step with 3 approvers and wait for escalation to happen.
4. Observe that escalation only happened for one approver; it didn’t happen for all other approvers.
Cause
This is an expected system behavior based on how the workflow escalation logic works.
According to the escalation configuration, the workflow would escalate to the manager of the current approver.
However, in this case, the manager for two of the approvers happens to be the third approver in the same step. This is why escalation only happened to the manager, not to the other two approvers.
Resolution
This isn’t a system issue. The workflow functioned as designed. Escalation doesn’t occur for the approvers whose escalate is also part of the current step’s approver group.
See Also
Keywords
Workflow Escalation, Approver Manager, Workflow Step, Expected Behavior, Employee Central, EC Workflow , KBA , LOD-SF-EC-WFL , Workflows - Configuration, Tools, Objects & Rules , Problem
SAP Knowledge Base Article - Public