SAP Knowledge Base Article - Public

3744771 - Exclamation Mark on Custom Field in Pricing Analysis While Condition Record Found

Symptom

In the pricing analysis of a sales order item, for a specific condition, there is exclamation mark on a custom field, but this access sequence still with status "Condition record has been found".

Environment

SAP S/4 HANA Cloud Public Edition

Reproducing the Issue

  1. Open the sales order in display mode.
  2. Select the affected item and choose Item Conditions.
  3. Choose Analysis.
  4. Expand the affected condition type and select the relevant access sequence.
  5. Observe a yellow exclamation mark next to the custom field used for pricing. However, the access details with status "Condition record has been found".

Cause

In corresponding pricing procedure, for this specific condition, or another condition after, there is an alternative calculation of condition amount routine related to PRCG_DOC_ITEM_CONDITION_AMOUNT BAdI which doesn't contain below mandatory content:

    MOVE-CORRESPONDING item_amounts TO item_result_amounts.
    MOVE-CORRESPONDING item_attributes TO item_result_attributes.
    MOVE-CORRESPONDING item_quantities TO item_result_quantities.
    MOVE-CORRESPONDING prcg_element_attributes TO prcg_element_result_amounts.
    MOVE-CORRESPONDING active_price_amounts TO active_price_result_amounts.

Resolution

Add above content into the PRCG_DOC_ITEM_CONDITION_AMOUNT BAdI, or remove corresponding routine number from corresponding pricing procedure.

See Also

Keywords

pricing analysis, custom field, exclamation mark, Condition record has been found, KOMK, KOMP, access sequence, BAdI, sales order , KBA , SD-BF-PR-2CL , Pricing (Public Cloud) , Problem

Product

SAP S/4HANA Cloud Public Edition all versions