Symptom
I‑9 reverification task shows incorrect due date after triggering I9 workflow manually via Manage data -> Trigger I-9 workflow
Environment
SAP SuccessFactors Onboarding 2.0
Reproducing the Issue
1. Go to Admin center -> Manage data -> Trigger I-9 workflow.
2. After triggering see home page card have due date as of today irrespective of document expiration date in I-9 audit trail for user
Cause
When TriggerI9Flow is created manually, triggeredDate is missing, so the system uses today’s date.
Automatic creation sets it correctly to the audit‑trail expiry, but the manual process does not.
Resolution
Currently this is a system expected behavior.
Engineering team is currently working on it and will be deployed
Preview Deployment: 09 Jun 2026
Production Deployment: 11 Jun 2026
See Also
- Refer to: a href="https://me.sap.com/notes/3637129" Identify The Date Picked To Trigger Reverification From I‑9 – Onboarding /a
- Refer to: a href="https://me.sap.com/notes/3525100" I‑9 Reverification is being assigned to incorrect Responsible User – Onboarding /a
- Refer to: a href="https://me.sap.com/notes/3544445" How to cancel I‑9 Reverification Task / Remove card from Homepage – Onboarding /a
Keywords
i‑9 reverification, incorrect due date, due date shows today, change responsible user, reassignment, manage data, TriggerI9Flow, overdue task, compliance process task, homepage card, to‑do due date, audit trail expiry date, triggeredDate, bpe startDate, onboarding , KBA , LOD-SF-OBX-I9 , i9 Compliance Form , Problem
SAP Knowledge Base Article - Public