Symptom
SuccessFactors jobs, such as Integration Center jobs or Intelligent Service Center jobs, fail when connecting to a SuccessFactors SFTP server, showing errors such as “access denied” or SFTP login failure.
However:
- The same SFTP credentials work successfully via browser or third‑party SFTP tools (for example, WinSCP)
- Other systems are able to connect to the same SFTP endpoint
- The integration worked previously and stopped without configuration changes in Integration Center
Environment
SAP SuccessFactors HCM Suite
Cause
The SFTP account was configured with IP restrictions and the SuccessFactors outbound IP addresses (listed in the KBA 2250792) were not on the allow list, resulting in the SFTP server denying connections from those IPs.
This allowlisting should be a standard when the SFTP account is created, so the SAP Operations team should investigate the root cause.
Resolution
Engage SAP Support (LOD-SF-PLT component) so they can engage Operations team to allow list the necesssary IPs and solve this.
See Also
Keywords
integration center, sftp, login failure, SSH_MSG_DISCONNECT 2, jsch, ip restriction, allow list, access denied for ip, sftp connection error, outbound ip, egress ip, authentication failure, sftp server, job failure, connectivity , KBA , LOD-SF-PLT-FTPE , SFTP Login Errors , LOD-SF-INT-INC , Integration Center , Problem
SAP Knowledge Base Article - Public