Symptom
E-Verify is not being triggered or processed as expected.
Environment
SAP SuccessFactors Onboarding
Reproducing the Issue
- Candidate completes I-9 forms and section 2 is also completed
- E-Verify does not trigger
Cause
The issue is caused by a misconfiguration or incorrect change applied to the FieldMetaOverrideConfiguration: GLOBAL_FILTER_CONFIG. When this configuration is altered incorrectly, the global filter override definitions for each filterkey become inaccessible to the Rule Evaluation Service. As a result, E-Verify that relies on these global filter conditions is not evaluated or triggered by the system.
Resolution
Changes to FieldMetaOverrideConfiguration are tracked in the system audit log. If the rollback needs to be performed by an administrator, it is recommended to cross-reference the audit log to confirm the exact timestamp and user responsible for the change, and restore the prior configuration accordingly.
Dear support engineers please refer to internal memo.
Keywords
E-Verify, e-verify not triggered, e-verify not processing, global filter, filterkey, GLOBAL_FILTER_CONFIG, FieldMetaOverrideConfiguration, RuleEvaluationService, workcountry, workstate, field meta override, Onboarding 2.0, OBX, global filter override, inaccessible, configuration change, rule evaluation , KBA , LOD-SF-OBX-EVF , Everify , Problem
SAP Knowledge Base Article - Public