SAP Knowledge Base Article - Public

3747866 - It is not possible to repeat a product inside Product Surveys

Symptom

When accessing a Product Survey and trying to add a product twice, error message "The following products already exist in the survey and won't be added" is shown.

Environment

SAP Cloud for Customer

Reproducing the Issue

  1. Go to Surveys > Surveys.
  2. Open the desired one.
  3. Click on Simulation button.
  4. Click on Add Products.
  5. Choose one and select the same product again.
  6. The warning message is shown "The following products already exist in the survey and won't be added" is displayed.

Cause

In C4C, the Product Surveys have a product duplication check, where it doesn't allow to add the same product more than once to avoid inconsistencies, and that is why the error message is shown. It is not possible to add the same product more than once in the Products facet neither on Simulation screen.

Resolution

This is the system standard behavior.

If the feature/functionality is required urgently, please refer to KBA 3475641 - Functionality Currently not Available. 

See Also

KBA: 3475641 - Functionality Currently not Available

Keywords

product survey, survey, product, twice, multiple times, more than once, add again, adding again, error, c4c, shows, shown, showed, showing, display, displays, displayed, displaying, appear, appears, appeared, appearing, add, repeat, insert , KBA , LOD-LE-SUR , Survey , LOD-LE-PRD , Product + Product Category , LOD-LE-PRL , Product List , LOD-CRM-ACT-VST , Visit Planning , Problem

Product

SAP Cloud for Customer core applications all versions