Symptom
When user adds multiple line items in Complaint Items with same Product and Item Category, following error is observed - "Duplicate item request found with the same item ID, product, and item category. Please provide unique item details and try again".
Environment
SAP Service Cloud Version 2
Reproducing the Issue
- Go to Cases.
- Open a Case in Detail View.
- Navigate to Complaint Items Tab.
- Click on Create (+) in All Items section.
- Select a Product and fill all necessary columns before clicking on Save.
- Repeat step 4 and 5 with the same Product.
- Notice that error occurs.
Cause
This is the current designed behavior of the system.
Resolution
As per the existing solution design, the assumption is that complaints related to different invoices (for example) are captured in separate cases.
- Creating separate cases for complaints originating from different invoices, even if they refer to the same product.
- Each case can then contain complaint items that is clearly associated with its respective invoice.
For any changes in the design, the customer is advised to post their requirement/vote for the requirement on the SAP Sales and Service Cloud Version 2 & SAP Enterprise Service Management Influence site
See Also
Keywords
Case, Complaint Items, Error, Product, Item Category, Item ID, Line Item, Duplicate, Product ID, Invoice, Service, Quantity , KBA , CEC-CRM-CAS , Case Management for SAP Sales/Service Cloud , Problem
SAP Knowledge Base Article - Public