Symptom
The Business User is not able to see the Phone Number value within the Task view list.
Environment
- SAP Sales Cloud and SAP Service Cloud Version 2.
- SAP Sales Cloud Version 2.
- SAP Service Cloud Version 2.
Reproducing the Issue
- Login in the tenant with user LMN (where LMN represent the Business Username).
- From the Navigation Menu go to the Activity Manager and click on the Task View List.
- Search and open the Task PQR (where PQR represent the task Id).
- Go to the header section of the task PQR.
- You can see the standard field Normalized Phone Number is having value as NNN (Where NNN represents some phone number value).
- Go to back to Task owl, here for the same task PQR for column name Normalized Phone Number the value as NNN is not displayed.
Cause
The business user will be able to see the Normalized Phone Number value, if his/her business role is assigned to CTI Business Service and CTI related UI App.
Resolution
- Go to the System Settings.
- Go to the All Settings and click on Users hyperlink.
- Search and open the Business User LMN and click on Assigned Business Role tab.
- User LMN is assigned to the Role XYZ (where XYZ represents the Role Name).
- Open the Role XYZ and go to the Details tab.
- Assign to this role the Business Service as sap.crm.service.ctiService and enable App as sap.crm.service.ctiService .
- Now, user LMN will be able to see the Phone Number in Task Owl for the Task ID PQR.
Keywords
Task View List, Normalized Phone Number, Business Service, Business Role, App, sap.crm.service.ctiService , enable app name sap.crm.service.ctiService , Business User, Logon User , KBA , CEC-CRM-TSK , Task for SAP Sales/Service Cloud , Problem
Product
SAP Sales Cloud and SAP Service Cloud Version 2 all versions
SAP Knowledge Base Article - Public