SAP Knowledge Base Article - Public

3748514 - Production Task Status Remains "In Process" After Successful Response in ManageProductionLotsIn

Symptom

ManageProductionLotsIn service response is successful, but the production task status remains In Process in Task Control view instead of changing to Completed.

Environment

SAP Business ByDesign

Reproducing the Issue

  1. Go to Application and User Management work center.
  2. Choose Service Explorer view.
  3. Search for the service "ManageProductionLotsIn" .
  4. Select the service and download the WSDL file.
  5. Create a new project in the SoapUi.
  6. Execute the request payload in SoapUI.
  7. Successful message in response payload.
  1. Go to Production Control work center.
  2. Go to Task Control view.
  3. Search for the relevant production task.
  4. The production task status remains In Process instead of Completed in UI.

Cause

  • The ManageProductionLotsIn request payload does not contain ProductionTaskUUID Tag.
  • Without ProductionTaskUUID, the system cannot identify the exact production task that must be completed.

Resolution

  1. Query the ProductionTaskUUID using QueryProductionLotIn web service.
  2. Maintain the correct ProductionTaskUUID in the ManageProductionLotsIn request payload.
  3. Try executing the payload again.
  4. Verify in Task Control view that the production task status changes to Completed.

See Also

Documentation: Inbound Service Manage Production Lots

Keywords

ManageProductionLotsIn; ProductionTaskUUID; Production Task; Task Not Completed; API Success; Confirmation; Task Control; Production Control; ByD; SOAP; Confirmation Group; Completion Indicator; Execution DateTime; Manufacturing; Lot Confirmation , KBA , AP-PE-TSK , Production Task , Problem

Product

SAP Business ByDesign all versions