Symptom
The following errors occur after opening AO launcher file 'analysis.sapaox' from Fiori Launch Pad or transaction code RAAOE.
The launcher exited with errors, see log file for more details.
Addin returned an error. Check logfile of the addin!
Connection to server has been lost. All data sources have been disconnected. If you want to reconnect, press the Restart button below.
In AO log, the following error entry can be found:
ERROR connection to partner '<hostname:port>' broken
TIME XXXXXX
RELEASE 789
COMPONENT NI (network interface)
VERSION 40
RC -6
MODULE D:/depot/bas/789_REL/src/base/ni/nixxi.cpp
LINE XXXX
DETAIL NiIRead: P=XXXXX; L=XXXX
SYSTEM CALL recv
ERRNO 10054
ERRNO TEXT WSAECONNRESET: Connection reset by peer
COUNTER X
Environment
SAP Analysis for Microsoft Office
Reproducing the Issue
- Go to Fiori Launch Pad or execute transaction code RAAOE.
- Open AO launcher file 'analysis.sapaox'.
- The errors occur.
Cause
The connection in AO launcher file 'analysis.sapaox' is not correct or invalid.
Resolution
- Enable parameter ForceRefreshConnectionInfo under path File -> Analysis -> Customize Analysis -> Technical Configuration -> search for ForceRefreshConnectionInfo and tick it.
- Close and open AO again and test the previous steps.
See Also
Keywords
Addin returned an error, AfO, Check logfile of the addin, report, connection error, open AO report directly, no issue. , KBA , BI-RA-AO-XLA , Excel Addin , Problem
SAP Knowledge Base Article - Public