SAP Knowledge Base Article - Public

3749246 - Connection error while opening Analysis for Office workbook launcher file from Fiori Launch Pad or RAAOE

Symptom

The following errors occur after opening AO launcher file 'analysis.sapaox' from Fiori Launch Pad or transaction code RAAOE.

The launcher exited with errors, see log file for more details.
Addin returned an error. Check logfile of the addin!
Connection to server has been lost. All data sources have been disconnected. If you want to reconnect, press the Restart button below.

In AO log, the following error entry can be found:

ERROR       connection to partner '<hostname:port>' broken
TIME        XXXXXX
RELEASE     789
COMPONENT   NI (network interface)
VERSION     40
RC          -6
MODULE      D:/depot/bas/789_REL/src/base/ni/nixxi.cpp
LINE        XXXX
DETAIL      NiIRead: P=XXXXX; L=XXXX
SYSTEM CALL recv
ERRNO       10054
ERRNO TEXT  WSAECONNRESET: Connection reset by peer
COUNTER     X

Environment

SAP Analysis for Microsoft Office

Reproducing the Issue

  1. Go to Fiori Launch Pad or execute transaction code RAAOE.
  2. Open AO launcher file 'analysis.sapaox'.
  3. The errors occur.

Cause

The connection in AO launcher file 'analysis.sapaox' is not correct or invalid.

Resolution

  1. Enable parameter ForceRefreshConnectionInfo under path File -> Analysis -> Customize Analysis -> Technical Configuration -> search for ForceRefreshConnectionInfo and tick it.
  2. Close and open AO again and test the previous steps.

See Also

  • KBA 2083067 - How to maintain settings for Analysis Office
  • KBA 3254719 - General information about the usage of parameter ForceRefreshConnectionInfo and related settings

Keywords

Addin returned an error, AfO, Check logfile of the addin, report, connection error, open AO report directly, no issue. , KBA , BI-RA-AO-XLA , Excel Addin , Problem

Product

SAP Analysis for Microsoft Office 2.8