SAP Knowledge Base Article - Public

3749316 - Contact information not visible in latest people profile

Symptom

  • After enable latest people profile, the contact information section is no longer visible.
  • The same contact information was visible in the legacy people profile.

Environment

SAP SuccessFactors Employee Central

Reproducing the Issue

  1. Go to Latest People Profile for one sample user.
  2. Navigate to Personal Information.
  3. Observe that the Contact Information section is missing.

Cause

The phoneInfo configuration had the isPrimary field disabled and set as not mandatory, which is not a recommended configuration.

Resolution

  1. Go to Manage Business Configuration.
  2. Navigate to the HRIS element phoneInfo.
  3. Enable the isPrimary field.
  4. Set the isPrimary field to Required (mandatory).
  5. Save the configuration.
  6. Recheck the Latest People Profile to confirm the Contact Information section is visible.

Keywords

ppx, pp3, contact information, contactInfo, phoneInfo, isPrimary, missing, not visible, latest people profile, 1h 2026, personal information card, portlet, configure people profile, bcui , KBA , LOD-SF-EP-PPP , People Profile - Preview , LOD-SF-EC-PER , Person Data (All Person Data Types) , Problem

Product

SAP SuccessFactors Employee Central all versions ; SAP SuccessFactors HCM Core all versions