Symptom
In the Outlook Add-In, searching for a Task using the Task ID does not return any results. However, when searching using the Subject the Task is successfully found.
Environment
SAP Cloud for Customer core applications
Reproducing the Issue
- Open the Outlook Add-In
- Navigate to the Tasks
- Enter a valid Task ID in the search
- Execute the search
- Result: No results are returned
- Enter the Subject for the same Task in the search
- Execute the search
- Result: The Task is successfully retrieved
Cause
Searching for Tasks by ID is not supported in the current version of the Outlook Add-in.
The task search functionality is designed for keyword- and text-based lookups, primarily based on the Subject field.
Retrieving tasks by Task ID requires a separate technical process (batch ID lookup), which is not part of the Add-in’s interactive search capability.
Therefore, searches using Task ID do not return results, whereas searches using Subject work as expected.
Resolution
This is an expected system behavior
As a workaround, Tasks can be searched using the Subject or relevant keywords, which is supported and will return the expected results.
Keywords
KBA , LOD-CRM-GW-SCC , Invisible CRM - Smart Cloud Connect Solution , Problem
SAP Knowledge Base Article - Public