Symptom
Products are not showing in catalog page after sales area migration.
Environment
SAP SALES CLOUD CPQ
Reproducing the Issue
- Open the catalog and search for a product
- Nothing is loaded into catalog.
Cause
Sales Area not properly configured in Products.
Resolution
- In order to product become visible in Catalog, below information needs to be checked:
- Ensure the product is related to the Distribution Channel and Sales Organization of the current Sales Area (from the quote, or the default one if there is no quote loaded)
- If Standard CPQ product, this information is the main one to be checked if it is properly set
- Confirm the IsDeleted flag is set to False for the product in the sales area
- Verify DistributionChainSpecificStatus is not equal to 'ERROR'
- Verify CrossPlantMaterialStatus (in Products) is not equal to 2 (error status)
- Verify XDistributionChainStatus (in Products) is not equal to 'ERROR'
- Check that CrossPlantMaterialStatusValidFrom and XDistributionChainStatusValidFrom are earlier than the effective date from the quote (or today's date if there is no quote).
- Ensure the product is related to the Distribution Channel and Sales Organization of the current Sales Area (from the quote, or the default one if there is no quote loaded)
See Also
Keywords
catalog, products not visible, sales area, sales area migration, distribution channel, sales organization, sales org, CPQ , KBA , CEC-SAL-CPQ , Sales Cloud CPQ , How To
Product
SAP CPQ 2024
SAP Knowledge Base Article - Public