SAP Knowledge Base Article - Public

3750119 - Error "Zero or multiple items received" when updating delivery schedule using SOAP API "Delivery Schedule of Sales Scheduling Agreement - Update (B2B)"

Symptom

When using the SOAP API "Delivery Schedule of Sales Scheduling Agreement - Update (B2B)" for updating delivery schedule of multiple items, the payload is returning error "Zero or multiple items received".

Environment

SAP S/4HANA Cloud Public Edition

Cause

Multiple items were included in a single request, which is not supported by this API currently.

Resolution

  • Pass each item in a separate payload request when using the SOAP API "Delivery Schedule of Sales Scheduling Agreement - Update (B2B)", as by standard, passing multiple items in a single request is not supported yet. However, you can include multiple schedule lines of the same item under single request.
  • Consider creating a feature request for this business requirement. This will inform our developers as to what additional functionality should be considered for future releases. Refer the KBA 2963059 for more information.

See Also

Keywords

Delivery Schedule of Sales Scheduling Agreement - Update (B2B), SOAP API, zero or multiple items received, item update, unique customer reference, sales scheduling agreement API, public cloud. , KBA , SD-SLS-API-2CL , API (Public Cloud) , Problem

Product

SAP S/4HANA Cloud Public Edition all versions