Symptom
- Custom email trigger after New Hire Data Review step completion is not getting triggered.
- Custom email template is not triggering to the recipient.
Environment
SAP SuccessFactors Onboarding
Reproducing the Issue
- Email Service > Active Templates
- Select a template
- Define Email Content
- Select "Onboarding User ID Recipient Builder" in "To Recipient Builder" field
- Custom email not triggered
Cause
Configuration Issue:
- There was a problem in the email category, as a result, the email template is getting skipped.
- An incorrect content builder or recipient builder was used in the custom trigger resulting to the email notification getting skipped.
- Rule conditions
Resolution
User ID Recipient Builder is not applicable for the custom email which needs to be triggered to the specific responsible group members.
It is one of the system limitations.
If it need you may raise an enhancement request: 3521269 - How to Submit Feature Requests, Ideas or Enhancements for SAP for Me - SAP for Me
See Also
Keywords
Custom Email Trigger, Custom email NHDR Step, Email Services, Emails, NHDR, New Hire Data Review step email, Email not triggered, Content Builder, Onboarding User ID Recipient Builder, Custom Email Template, OBX, EML, ONB, ONB2, Onboarding, responsible group, members , KBA , LOD-SF-OBX-NF , Notifications Framework , Problem
SAP Knowledge Base Article - Public