SAP Knowledge Base Article - Public

3750348 - Error "Currency ABC does not exist" when replicating Customers to Sales Cloud V2

Symptom

You are replicating customers to Sales Cloud V2 and you are facing the error "Currency ABC does not exist" (where ABC means the currency code).

Environment

  • SAP Sales Cloud version 2
  • Sales Sales and Service Cloud version 2
  • Sales Sales and Service Cloud version 2 integration with ERP

Reproducing the Issue

  1. Replicate Customer from ERP with currency ABC
  2. On the Sales Cloud V2, click on the user icon.
  3. Click on System Settings.
  4. Go to "All Settings" tab.
  5. Open the Message Monitoring.
  6. Search for the erroneous message of customerERPReplicationMessageIn

Error: Currency ABC does not exist

Cause

The currency ABC is not activated on the system.

Resolution

To resolve the issue, please follow the steps below:

  1. On the Sales Cloud V2, click on the user icon.
  2. Click on System Settings.
  3. Go to "All Settings" tab.
  4. Open the Language, Region, and Currency.
  5. Under Currency tab, set the currency ABC as "active".

See Also

SAP Guide - Configure Currencies and Benchmark Currency

Keywords

V2, SSC, Sales Cloud, Version 2, Currency, Sales Cloud V2, Service Cloud V2, Integration, Customer. , KBA , CEC-CRM-DC , Data Connector for SAP Sales/Service Cloud , Problem

Product

SAP Sales Cloud and SAP Service Cloud Version 2 1.0