SAP Knowledge Base Article - Public

3750354 - Error "item category 0 doesn't exist" (Error message ME719) occurs only with certain language (Chinese)

Symptom

An error occurs when using the app "Create Purchase Order – Advanced" or transaction ME21N while logged on in Chinese only.

  • Error message: "Item category 0 doesn’t exist." Message ID ME719

Environment

SAP S/4HANA Cloud Public Edition

Reproducing the Issue

  1. Log on to the system with the logon language set to Chinese.
  2. Start the app "Create Purchase Order – Advanced" or run transaction ME21N.
  3. Enter item details for the purchase order.
  4. Observe the error "Item category 0 doesn't exist" (ME719).

Cause

Missing language-dependent descriptions (translations) for the affected item category in the configuration for the user's logon language (Chinese), which leads to validation failure and message ME719.

Resolution

  1. Log in with affected language (Chinese), open SSCUI 102909 <Define Document Types for Purchase Orders>.
  2. Select the affected PO type and double click on 'Allowed item categories'.
  3. Add New Entries, maintain the language-dependent descriptions for the affected item category, by selecting the value help of ItCat.
  4. Save and activate the configuration, the issue will be resolved.

Keywords

ME21N, create purchase order advanced, item category 0 doesn’t exist, ME719, F5832, chinese language, logon language, item category translation, T163, missing language-dependent description, purchase order error, s/4hana cloud public edition, operational procurement, mm-fio-pur-po, po creation in chinese, 项目类别 0 不存在 (请改正), 消息编号 ME719 , KBA , MM-FIO-PUR-PO-2CL , Fiori UI for Purchase Orders (Public Cloud) , Problem

Product

SAP S/4HANA Cloud Public Edition all versions