SAP Knowledge Base Article - Public

3750375 - How to Re-Assign a Territory to an Account Using Data Workbench in SAP Cloud for Customer

Symptom

After successfully deleting an existing territory assignment via Data Workbench, it is not possible to create a new territory assignment for the same account. When attempting to import a new assignment using the Update operation, the following error message is displayed:

"The server has not found any resource matching the Data Services Request URI"

Environment

SAP Cloud for Customer

Reproducing the Issue

  1. Log in to SAP Cloud for Customer.
  2. Go to the Data Workbench work center.
  3. Go to the Export view.
  4. Select Standard Object.
  5. Choose the service Sales Territory Account.
  6. Use Customer_ID as filter and enter the account ID.
  7. Click Next and then Export Data.
  8. Download the CSV file from the Monitor view.
  9. Open the file and add a column ToBeDeleted with the value TRUE.
  10. Go to the Import view.
  11. Select Individual Object and operation Update.
  12. Select Standard Object and choose Sales Territory Account.
  13. Click Next and upload the file.
  14. Click Next and then Import.
  15. Verify in the Monitor that the deletion was successful.
  16. Try to create a new territory assignment for the same account repeating the import steps with the new Territory_ID.
  17. Import fails with the error message: "The server has not found any resource matching the Data Services Request URI".

Cause

Using the Update operation to create a new account–territory assignment is not supported for this object; a new assignment must be created via Upsert with the required key fields.

Resolution

  1. Log in to SAP Cloud for Customer.
  2. Go to the Data Workbench work center.
  3. Go to the Import view.
  4. Select Individual Object.
  5. Select the operation Upsert.
  6. Select Standard Object.
  7. Choose the service Sales Territory Account.
  8. Click Next.
  9. Click Download Template and open the file Sales Territory Account.csv.
  10. Fill in the following fields:
  • External_Key: mandatory
  • Territory_ID: the new territory ID to be assigned
  • Customer_ID: the account ID
  • Manual_Assignment_Indicator: true
  • Leave all other fields empty.

   11. Save the file as .csv.
   12. Go back to the Import view and repeat steps 3 to 8.
   13. Upload the file.
   14. Click Next and then Import.
   15. Check the status in the Monitor view.
   16. Go to the Export view and filter by Customer_ID to confirm the new Territory_ID is correctly assigned.

See Also

  • KBA 3086020 - You Can Not Update Territory ID via Data Workbench
  • KBA 2735885 - How to Remove Territory from Account Using Data Workbench

Keywords

Territory reassignment; Data Workbench import; Sales Territory Account; Territory ID update; Territory assignment error; Data Workbench Upsert; Data Workbench Update error; Territory assignment creation; Account territory; Data Workbench CSV; Territory re-assign; Manual assignment indicator; External Key mandatory; Sales Territory import; Territory assignment delete; Data Workbench error; Resource not found; Territory assignment C4C; Data Workbench individual object; Sales Territory Upsert , KBA , LOD-CRM-INT-DWB , Data Workbench , How To

Product

SAP Cloud for Customer core applications all versions