Symptom
You want to remove an IAM App from a Business Role, but when you select the IAM App, the "Remove" button is unavailable. Only the "Deactivate" option is available.
Environment
SAP S/4HANA Cloud Public Edition
Reproducing the Issue
- Go to Maintain Business Roles app
- Open a Business Role
- Click on "Edit"
- Go to "IAM Apps" tab
- Select an IAM App
- The "remove" button is not clickable
Cause
IAM Apps that are added to the Business Role through Business Catalogs can't be removed.
The "Remove" button is intended only for the IAM Apps that were added to the Business Role using the Direct App assignment, that is, using the "Add" button.
Resolution
IAM Apps added through Business Catalogs can only be deactivated. Deactivate the app instead of trying to remove it.
See Also
Keywords
business role, iam app, deactivate, remove, delete, button, greyed out, clickable, not possible, direct app assignment, role, maintain , KBA , BC-SRV-APS-IAM , Identity and Access Management , Problem
SAP Knowledge Base Article - Public