SAP Knowledge Base Article - Public

3750976 - Adhoc Report - Unable to Filter Candidate Background Picklist Field Due to Anonymized Value - Recruiting Management

Symptom

In Ad Hoc Reporting, when attempting to filter on picklist fields from Candidate Background Elements, the page keeps loading.

Environment

SAP SuccessFactors Recruiting Management

Reproducing the Issue

  1. Create a new Table report.
  2. Setup Filters.
  3. Select a picklist field from any Candidate Background Element (for example, "Candidate: Education" or "Candidate: Work Experience").
  4. Observe that the page keeps loading
  5. Check the browser‘s Developer Tools (Network tab) and observe an application error ("fingerprint": "7f1bd5f11ae44477a390016b3a0bfcd7fd62ef0a").

(For SAP Support: refer to internal memo)

Cause

This is a known issue. Currently, application is updating BG-picklist fields to 'Anonymized' value instead of '-99999'. Hence, its causing error in Reporting.

Resolution

The fix for this issue is planned to be deployed on 2H 2026 release (b2611). For release timelines, please review SAP SuccessFactors Product Release & Road Map Information.

Workaround

Apply a report filter using "Anonymized Flag = Non-Anonymized" to exclude anonymized records from the results.

See Also

Keywords

RCM-158225, Report, Error, Filter, Picklist, Background, Candidate Profile, Education, Work Experience, invalid number, exception, Anonymized, attribute value is not a number , KBA , LOD-SF-RCM-REP , Reporting & Analytics, Data Imports & Exports , Problem

Product

SAP SuccessFactors Recruiting all versions