Symptom
Customer was not able to fetch the values of customer part number using reports
Environment
SAP Business ByDesign
Reproducing the Issue
- Go to Business Analytics Work center
- Go to Design Reports view.
- Preview the report “Customer Demand Details”.
- Add the field “Customer Part Number”.
- In the view, add the row field “Customer Part Number”.
- Observe that the report displays only some values for customer part numbers.
Cause
Currently, there is no standard report that appropriately fetches the Customer Part Number values as required.
Resolution
- Go to Business Analytics work center
- Go to Design Reports view.
- Create a new report based on the data source “Product Customer Part Number Master Data”.
- Add required fields such as Customer Part Number, Product ID, and any additional identifiers needed for your use case.
- Add “Customer Part Number” as a row field in the report view to list all values.
- Save and preview the report to verify that all Customer Part Number values are displayed.
- Use this custom report for exports or downstream processes instead of standard transactional reports that do not expose complete Customer Part Number data.
See Also
Keywords
customer part number, product customer part number master data, missing values, not fetching, report, custom report, data source, business analytics, design reports, reporting, customer demand details, field not showing, master data, analytics , KBA , SRD-MD-PRD-PRD , Product , Problem
Product
SAP Business ByDesign all versions
SAP Knowledge Base Article - Public