Symptom
When working with extension fields its value gets defaulted to UTC format when used as placeholder in e-mail templates (like in tickets).
Environment
SAP Sales/Service Cloud
Reproducing the Issue
- Go to the Service work center.
- Go to the Tickets work center view.
- Open a ticket ABC that contains extension field DEF (where ABC is the ID of a ticket and DEF is a date-time extension field).
- Go to the Interactions tab and choose the three dot icon and then 'Reply All' to an email GHI (where GHI is an e-mail of ABC).
- Click in the templates button in the pop-up that appears
- Select template JKL (where JKL is an e-mail template that uses DEF as a placeholder).
- Observe that the field is displayed in UTC rather than current user’s profile time zone.
Cause
- Extension date-time values are stored in the backend as UTC.
- Email template placeholders are processed in the backend, and the user profile time zone (from settings) is not considered during this backend parsing.
Resolution
- This is the current system design: template placeholders for extension date-time fields are processed in the backend and use values stored in UTC.
- There is no standard configuration to define or override time zone handling for date-time placeholders in email templates.
- If a change in behavior is required, submit an improvement request via the Influence Session.
See Also
refer to: SAP Community: Cloud for Customer
Keywords
email template, placeholder, time zone, UTC, extension field, customer due date, ticket, service request, interactions, backend processing, kut, date-time format, email rendering, template processing, profile time zone , KBA , LOD-CRM-SRP , Service Request Processing , AP-RC-UIF , C4C UI Framework , Problem
Product
SAP Cloud for Customer core applications all versions
SAP Knowledge Base Article - Public