SAP Knowledge Base Article - Public

3751205 - E-mail Template Placeholder Shows Extension Field Date-Time in UTC Instead of User Time Zone Settings From Profile Menu

Symptom

When working with extension fields its value gets defaulted to UTC format when used as placeholder in e-mail templates (like in tickets).

Environment

SAP Sales/Service Cloud

Reproducing the Issue

  1. Go to the Service work center.
  2. Go to the Tickets work center view.
  3. Open a ticket ABC that contains extension field DEF (where ABC is the ID of a ticket and DEF is a date-time extension field).
  4. Go to the Interactions tab and choose the three dot icon and then 'Reply All' to an email GHI (where GHI is an e-mail of ABC).
  5. Click in the templates button in the pop-up that appears
  6. Select template JKL (where JKL is an e-mail template that uses DEF as a placeholder).
  7. Observe that the field is displayed in UTC rather than current user’s profile time zone.

Cause

  • Extension date-time values are stored in the backend as UTC.
  • Email template placeholders are processed in the backend, and the user profile time zone (from settings) is not considered during this backend parsing.

Resolution

  1. This is the current system design: template placeholders for extension date-time fields are processed in the backend and use values stored in UTC.
  2. There is no standard configuration to define or override time zone handling for date-time placeholders in email templates.
  3. If a change in behavior is required, submit an improvement request via the Influence Session.

See Also

refer to: SAP Community: Cloud for Customer

Keywords

email template, placeholder, time zone, UTC, extension field, customer due date, ticket, service request, interactions, backend processing, kut, date-time format, email rendering, template processing, profile time zone , KBA , LOD-CRM-SRP , Service Request Processing , AP-RC-UIF , C4C UI Framework , Problem

Product

SAP Cloud for Customer core applications all versions