Symptom
When attempting to change the background image for a user whilst proxying as the user, an error is thrown:
"An application error occurred. Please try again later, or notify support if the issue keeps occurring."
Environment
SuccessFactors Employee Profile 2605
Reproducing the Issue
- Log in to instance and proxy as a user with permission to edit background image.
- When a new image is selected and clicked save, an application error occurs.
Cause
Expected behavior.
The problem is that USER_EXPRESSIVE_PHOTO (background image) is intentionally restricted to self-edit only — it explicitly blocks any proxy/admin edit of another user's background photo. The proxying admin is being rejected by design.
Resolution
In order to change the background image, the login user must change on self.
See Also
- Configuring Background Images for the Latest People Profile | SAP Help Portal
- 2398302 - Picture and Background Image People Profile
- 2237733 - How to Upload a Background Image in People Profile - SuccessFactors Employee Profile
Keywords
background image, edit, application error, USER_EXPRESSIVE_PHOTO, proxy, employee profile. , KBA , LOD-SF-EP-SPP , People Profile - Spotlight , LOD-SF-EP-PHO , Photo Management , How To
SAP Knowledge Base Article - Public