SAP Knowledge Base Article - Public

3752290 - Validation is Triggered Even When Assigned User Lacks Visibility or Access to Categories through Business Role

Symptom

The category fields are not displayed when creating a Phone Call from the Account Detail view when the business role has only SAP Sales Cloud Version 2 SKU (8014321). However, a validation error still appears.

Environment

SAP Sales Cloud and SAP Service Cloud Version 2

Reproducing the Issue

  1. Open the System Settings
  2. Go to the Users and Control
  3. Select Roles
  4. Create a business role that includes only SAP Sales Cloud Version 2 SKU (8014321)
  5. Assign this role to a user
  6. Sign in as that user
  7. Navigate to the Account worklist
  8. Open any account
  9. Create Log Call

Result: The validation for the Categories set up in the Extensibility Administration is triggered.

Cause

  • Categories in Phone Call creation are controlled by Service SKU; without SAP Service Cloud Version 2 SKU (8012579), the component that enables category selection (sap.crm.service.serviceCategoryService) is not available, so category fields are hidden by design.
  • Validation rules defined in Extensibility Administration Tool apply globally and cannot be scoped by Business Role; therefore, a category validation can still trigger even when the field is not visible for a Sales-only role.

Resolution

Add SAP Service Cloud Version 2 SKU (8012579) to the Business Role.

See Also

Keywords

sales sku, service sku, category, categories, validation, error, serviceCategoryService, message , KBA , CEC-CRM-PH , Phone Calls for SAP Sales/Service Cloud , Problem

Product

SAP Sales Cloud and SAP Service Cloud Version 2 all versions