Symptom
- An error occurs when trying to create a live connection to Snowflake using the Acquire Data area.
- Error message: "Snowflake connection could not be created. This might be due to the system being unreachable or invalid connection details. Please check your input and try again."
- Logon credentials were verified by the Snowflake team.
Environment
- SAP Analytics Cloud 2026.2.19 (Client)
- SAP Analytics Cloud 2026.2.16 (Server)
Reproducing the Issue
- Generate encript private key by referring https://docs.snowflake.com/en/user-guide/admin-account-identifier
- In SAP Analytics Cloud, from the side navigation, choose Connections Add Connection.
- Choose +.
- Choose Snowflake.
- Enter a connection name.
- Optional: Enter a description.
- Enter the snowflake account name.
- Enter the username.
- Choose Select Key File to browse and select the .p8 private key file.
- Enter the passphrase.
From the har trace , below error can be confirmed:
errorDetails": [
{
"message": "Failed to execute statement exec. Component = Statement. Reason = Unable to connect remote source: DPAdapterAccess::Connect:[Driver error] The certificate store could not be opened: Failed to decode PKCS8 private key: Error decoding key: Too much data. (adapter type: Snowflake, source name: XXXXXXXX)",
"bUIMessage": false,
"bWarning": false
}
Cause
This issue is currently under investigation of development team.
Resolution
This issue is currently under investigation of development team.
See Also
Keywords
snowflake live connection, acquire data, connection could not be created, unreachable, invalid connection details, account identifier, account locator, hostname, domain suffix, account name invalid, sac live, correlation id, login history, har trace , KBA , LOD-ANA-LDC-HAN , SAC Live Data Connection HANA , Problem
SAP Knowledge Base Article - Public