Symptom
No documents are visible in the Onboarding Documents after the onboardee is hired or moved to Employee Central, and the section appears blank despite permissions being configured per guidance.
Environment
SAP SuccessFactors Onboarding
Reproducing the Issue
- Go to the Onboarding dashboard.
- Search for the onboardee.
- Open the onboardee’s Onboarding dashboard.
- Click Actions.
- Select Onboarding Documents.
- Observe that the section is blank (no documents listed).
Cause
The target population of the permission roles did not include internal hires (employees) after the hire was moved to Employee Central.
Resolution
- Go to Manage Permission Roles.
- Identify the relevant Onboarding permission role(s) that should allow viewing Onboarding Documents.
- Edit the role and navigate to Role Assignments/Target Population.
- Set the target population to include internal hires (employees), as applicable.
Please note: it is important to ensure this target population is configured on an Onboarding permission role. Even if "All (Employees)" target population is set to an Employee Central or Recruiting role, the configuration might not work.
See Also
Keywords
onboarding, documents, blank, not, visible, internal, hire, employee, central, target, population, role, based, permissions, rbp, role, assignments, onboarding, dashboard, view, new, hire, documents, permissions, onb, obx, document, visibility, employees , KBA , LOD-SF-OBX-DBD , Dashboard , LOD-SF-OBX , Onboarding 2.0 , Problem
SAP Knowledge Base Article - Public