Symptom
When creating Sales Orders via web service, the item numbering sequence in the created Sales Order does not follow the same sequence maintained in the payload.
Environment
SAP Business ByDesign
Reproducing the Issue
- Go to the Sales Orders work center.
- Go to the Sales Orders view.
- Show All Orders and search for the Sales Order ID XYZ (XYZ represents the ID of the sales order).
- Click Edit, then View All.
- Navigate to the Items Tab.
Observe that the item numbering sequence differs from the sequence provided in the payload.
Cause
The payload contains multiple items with one kit header item along with other item types. During Sales Order creation, kit sub items are fetched internally from the kit header and item numbers are assigned internally. Due to regrouping of items internally for kit sub items, the sequencing maintained in the payload is not followed in the created Sales Order.
Resolution
In order to have correct sequencing with kit header items, no need to provide item number sequencing in the payload. Once payload gets executed, it will automatically adjust item number internally in sequence along with kit header and kit sub items.
Remove the below item number sequencing from the payload:
<ID>10</ID>
After removing the item number sequencing from the payload, the Sales Order will be created successfully with the correct sequence.
Keywords
Sales Order; Item Number Sequence; Web Service; Kit Header; Kit Sub Item; Item Sequencing , KBA , SRD-CRM-ORD , Orders & Contracts , Problem
SAP Knowledge Base Article - Public