SAP Knowledge Base Article - Public

3753213 - Unable to set view as 'Default' in User Settings for 'Default Values' - SAP S/4HANA Cloud Public Edition

Symptom

No option to set a view as 'Default' that was created in the "Default Values" section of User Settings.

Environment

SAP S/4HANA Cloud Public Edition

Reproducing the Issue

  1. Click the avatar menu (top right) and choose 'Settings'.
  2. Navigate to 'Default Values'.
  3. Maintain some field values, open the 'Saved Values' dropdown, and choose 'Save As' to create a new view.
  4. Use Manage to set the view as Public.
  5. Attempt to set this public view as the default for other users.

Cause

It is not possible to set a default view for the 'Default Values' setting.

Resolution

Note that the system always uses "Saved Values" as the active default for each use.

To apply the updated default values follow the steps below:

  1. Apply values to fields in Default Values.
  2. Click the 'Saved Values' dropdown and select 'Save as' and toggle 'Public'.
  3. Click 'Save'.
  4. This will then apply the values to the 'Saved Values'.
  5. Use the 'Saved Values' dropdown to import/apply the relevant 'Public' view into their own "Saved Values".

See Also

Keywords

default values, saved values, public view, manage views, user-specific defaults, enforce defaults, role-based defaults, import template, my home settings, fiori launchpad, s/4hana cloud public edition, cannot set default for others, default values view, CA-FLP-FE-COR, avatar, settings, user settings , KBA , CA-FLP-FE-COR , SAP Fiori Launchpad Frontend Core and Services , Problem

Product

SAP S/4HANA Cloud Public Edition all versions