SAP Knowledge Base Article - Public

3753618 - Assigning Business Role when Provisioning Multiple Users is Not Working

Symptom

  • Groupware Provisioning is not working as expected
  • Business Roles are not assigned after provisioning multiple users

Environment

SAP Cloud for Customer core applications

Reproducing the Issue

  1. Navigate to E‑Mail Integration
  2. Go to Groupware Settings
  3. Select Provisioning > Provisioning multiple users.
  4. Expectation is that the selected business role is assigned automatically to the selected users
  5. Observe that some users do not receive the role

Cause

  • Data inconsistencies in the user’s contact details prevented automatic role assignment during provisioning.
  • Missing user’s email in contact data.
  • Missing department and/or the user’s role information in contact data.
  • Duplicate contact records existing for the same user.

Resolution

Validate each affected user’s contact master data:

  • Ensure a valid user’s email is maintained.
  • Maintain department and the user’s role information.
  • Ensure only one active contact record exists per user; merge or remove duplicates.

See Also

Keywords

groupware settings, provisioning multiple users, business role assignment, end user - groupware settings, INV_SOL_GW_END_USER, role not assigned, email integration, outlook integration, ui rules, contact data, missing email, department information, duplicate contacts, automatic provisioning, cloud for customer , KBA , LOD-CRM-GW-SCC , Invisible CRM - Smart Cloud Connect Solution , LOD-CRM-EMP , Employee , How To

Product

SAP Cloud for Customer core applications all versions