Symptom
During inbound processing (/SDEDI – ORDR_IN – 1), the system does not create the customer sales order. The following error can be seen in Message Dashboard:
- "Supplier ID & not found" (message no. EDI_SD410).
Environment
SAP S/4HANA Cloud Public Edition
Cause
The supplier ID (field SupplierPartyID in the payload) is fetch from the purchase order to the sales order creation payload in 2 possible ways:
- The field Account with Supplier (LFM1-EIKTO) in the supplier master data.
- If this field is empty, the supplier ID is defaulted to the purchasing organization used in the purchase order.
For both occasions, the SupplierPartyID must be mapped in the configuration activity 'Convert External to Internal Partner Numbers' to an internal customer.
Resolution
To make sure the correct supplier is passed on sales order creation, maintain correctly the field 'Account with Supplier' (LFM1-EIKTO) in the supplier master data. Follow bellow steps:
- Go to app Maintain Business Partner (BP)
- Enter business partner number
- Change the BP role to 'Supplier'.
- Go to tab 'Purchasing Data', section 'Sales Data'.
- Maintain a value in the field and save
Note: the value maintained in this field should be the external number mapped to the internal number in the configuration activity 'Convert External to Internal Partner Numbers'.
See Also
Keywords
ORDR_IN, /SDEDI, EDI_SD410, supplier id not found, inbound sales order, message dashboard, convert external to internal partner numbers, SupplierPartyId, customer mapping, sales order creation failure, EDIsales order, application log error, party node, public cloud, internal customer, customer number , KBA , SD-SLS-EDI-2CL , S/4HANA: Sales EDI Messages (Public Cloud) , Problem
SAP Knowledge Base Article - Public