SAP Knowledge Base Article - Public

3754417 - Performance Data Not Visible in Trend Card/Performance History after 1H 2026 Production Release

Symptom

After the 1H 2026 production release, several customers reported an issue wherein the Performance data was not visible in the Trend Card/Performance History section of the Latest People Profile.

Environment

SAP SuccessFactors Performance Management

Reproducing the Issue

  1. Proxy as Affected User
  2. Open People Profile of the affected user
  3. No data for PM History Block.

Cause

Its primarily caused by the missing “Performance > View Overall Ratings from Forms” permission in Role-Based Permissions (RBP). 

As mentioned in the Configuring Performance History Card for Full Profile,"View Overall Ratings from Forms”  & " View Goal Ratings from Forms " are required as prerequisites in the new PPX experience to view PM History.

Resolution

Workaround:

"View Overall Ratings from Forms”  & " View Goal Ratings from Forms " are required as prerequisites in the new PPX experience to view PM History.  Once these permissions are granted to the affected users/roles, the Performance data becomes visible again in the Latest People Profile. 

Keywords

KI1H2026,Latest People Profile, PPX,History ,Portlet,Block , KBA , LOD-SF-PM-POD , Home Page, Pods and Portlets, To Do List , Known Error

Product

SAP SuccessFactors Performance & Goals 2605