SAP Knowledge Base Article - Public

3754794 - Error "field REQUESTED_UOM is not an input field" when adding items in batch through API Sales Order (A2X, OData V4)

Symptom

When creating sales order and adding items in batch with API Sales Order (A2X, OData V4), the following error is received:

  • "Field REQUESTED_UOM is not an input field" (SLS_LORD/025)

Despite the error message, the new sales order item is created successfully.

Environment

SAP S/4HANA Cloud Public Edition

Cause

The response message occurs only when adding a new item through the API to an existing order whose last existing item is a third‑party item with a purchase order already created. Since the UOM of that existing item cannot be changed, the message is erroneously raised in the response.

For example: There's an order 1234567890, it has item 10 which is a third-party item and a purchase order exists for this item (complete or partial quantity): the UOM of this item 10 cannot be changed. Then, if trying to add a new item to the order, then the message "Field REQUESTED_UOM is not an input field" is received. Nevertheless, the item 20 passed in the payload is still created successfully.

Resolution

According to our development experts, the root cause of the mentioned issue was identified. The correction for this matter is going to be delivered within CE2608, which is planned to be delivered from July 17th to August 16th.

Please notice that this is the current state of planning and may be changed by SAP at any time without notice. Refer to bellow maintanance schedules for further updates.

Keywords

odata v4, sales order a2x, requested_uom, not an input field, SLS_LORD/025, batch, add item, third-party item, purchase order created, uom, sales order api, patch request, error in response, CE2608 , KBA , SD-SLS-API-2CL , API (Public Cloud) , Problem

Product

SAP S/4HANA Cloud Public Edition all versions