Symptom
When viewing the performance history card in people profile, users see an error:
There’s no data yet
Environment
- SAP SuccessFactors 360 Reviews
- SAP SuccessFactors People Profile
- SAP SuccessFactors Performance Management
Reproducing the Issue
- Log into SuccessFactors
- In the module picker, select People Profile
- Select the Performance and Goals section
- The Performance History card shows the error
Cause
- Employee is not in the target population
- Missing ratings permissions
- Rating scale not configured
- Form template not included in card configuration
- In-progress forms not included
Resolution
Employee is not in the target population
When searching for other employees, the Performance History card only displays data for users within the defined target population. To verify if the employee is included in the user's target population, review Implementing Role-Based Permissions - Assigning a Permission Role.
Missing ratings permissions
The required permissions to view ratings may not be enabled. Depending on your configuration, you may need to enable View Overall Ratings from Forms, View Goal Ratings from Forms, or both. Please review Implementing and Managing Performance Management - Configuring Performance History Card for Full Profile - Prerequisites for details on each permission.
Rating scale not configured
A rating scale is required to standardize ratings across different forms in the updated People Profile. Ensure a rating scale is selected for the Rating Scale field. Refer to Implementing and Managing Performance Management - Configuring Performance History Card for Full Profile - Procedure for configuration steps.
Form template not included in the card configuration
If the employee only has forms tied to a template that is not included in the card configuration, no data will appear. Confirm the relevant template is included in the Form Template field using steps in Implementing and Managing Performance Management - Configuring Performance History Card for Full Profile - Procedure.
In-progress forms not included
If the employee only has in-progress forms, they may not display depending on configuration settings. Enable the Include In-Progress Forms setting by referencing Implementing and Managing Performance Management - Configuring Performance History Card for Full Profile - Procedure.
See Also
- Implementing Role-Based Permissions - Assigning a Permission Role
- Implementing and Managing Performance Management - Configuring Performance History Card for Full Profile - Prerequisites
- Implementing and Managing Performance Management - Configuring Performance History Card for Full Profile - Procedure
Keywords
performance history, there's currently no data for you, rating scale required, performance history card, full profile, performance management feature settings, form drill down, role-based permissions, performance and goals, profile card, no data error , KBA , LOD-SF-PM-POD , Home Page, Pods and Portlets, To Do List , LOD-SF-MTR-POD , Home Page, Pods and Portlets, To Do List , LOD-SF-EP-FPP , People Profile - Full Profile , LOD-SF-EP-UI , People Profile UI (PP3 UI) , Problem
SAP Knowledge Base Article - Public