Symptom
The company has recently changed the Microsoft 365 server/tenant, and it's necessary to re-establish the integration with this new environment.
However, the users which were configured on the old server are receiving the error: "The requested user 'xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx' is invalid."
The issue is not happening for new reprovisioned users.
Environment
SAP Cloud for Customer
Reproducing the Issue
1. Go to E-Mail Interagtion work center.
2. Open the "Groupware Settings" work center view.
3. Open the "ABC" user.
4. You can see the error: "The requested user 'xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx' is invalid."
Cause
Based on the current error, the issue appears to be related to the Microsoft 365 tenant/user mapping.
The connector is trying to access this Graph user ID: xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx
However, Microsoft Graph returns that the requested user is invalid.
This usually means that the stored Graph user ID does not exist in the currently connected Microsoft 365 tenant.
Resolution
Since the Microsoft 365 tenant was changed, the affected users most likely need to be reconnected/reprovisioned, so the correct Graph user IDs from the new tenant are stored.
See Also
SAP C4C Server-Side Integration supports OAuth 2.0 with Microsoft Graph API for Groupware Integration.
This is exactly the supported Graph API-based mailbox connectivity option.
However, the following points do not apply to the standard C4C SSI setup:
- manual Client ID configuration in C4C
- manual Client Secret configuration in C4C
- maintaining a custom Azure OAuth app registration directly in the Groupware UI
For the standard SSI Graph API flow, the configuration is completed through the Microsoft admin consent / login flow, not by manually entering Client ID and Client Secret in C4C.
Keywords
C4C; SSI; Server Side; Error; Requested; User; Invalid; , KBA , LOD-CRM-GW-SCC , Invisible CRM - Smart Cloud Connect Solution , How To
SAP Knowledge Base Article - Public