SAP Knowledge Base Article - Public

3756213 - Manage Job Profiles shows error when users have view-only permission in new Admin Experience UI

Symptom

  • An error occurs when accessing Manage Job Profiles even though required view permissions are assigned.
  • Error message: "???JDMNG_JOB_PROFILE_ERROR_LOAD_PROFILE???" or "Failed to load job profile. Please try again."

Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.

Environment

SAP SuccessFactors Job Profile Builder

Reproducing the Issue

  1. Log in to instance and access the Manage Job Profile Page with new Admin Experience UI
  2. Note that the logged in user currently only has view permission for Job profile
  3. Try to view any Job Profile and notice the error.



  4. Disable the new Admin Experience UI and then cross check that the Job profile is accessible without any error.

Cause

This is a Known Issue

Resolution

The fix for this issue is planned to be deployed with the M2605p3 patch (planned 02-June-2026 for Preview and 04-June-2026 for Production)

As a temporary workaround, grant Edit permission in Manage Job and Skill Profile Visibility > Job Profile > Edit to affected roles to allow viewing Job Profiles.

See Also

Keywords

KI1H2026, manage job profiles, job profile builder, view-only permission, edit permission required, new ui, access error, permissions, role-based permission, manage job and skill profile visibility, job profile edit, m2605p2, error placeholder, admin experience, profile access, new admin experience, view permission, manage job profile page, WEF-170055, PTCH-50131 , KBA , LOD-SF-TIH-JPB , Job Profile Builder , Known Error

Product

SAP SuccessFactors HCM Suite 2605