SAP Knowledge Base Article - Public

3756566 - Global Search not showing User Status after enabling Enhanced People Search

Symptom

Cannot see the user status "(Inactive)" when searching in Global Search. 

Environment

SAP SuccessFactors HCM Suite

Cause

The field IsActive was not yet supported by search APIs before 2605 release. 

Resolution

For Productive environments in which customers enabled the Enhanced People Search before the global push (see KBA 3728404 - Enhanced People Search Enablement and Re-indexing Schedule – SAP SuccessFactors 1H 2026 - SAP for Me), it is necessary to run the  Rebuild Company Index for Enhanced People Search job from Scheduled Job Manager. 

  • If you have manually enabled the Enhanced People Search in Company System and Logo Settings
  • Go to Scheduled Job Manager > create job > create a one-time job from the type  Rebuild Company Index for Enhanced People Search. 
  • Run it now

See Also

Keywords

global search, enhanced people search, employment status, inactive users, status not displayed, people search results, directory search, elasticsearch-based search, legacy solr, header search, sf , KBA , LOD-SF-PLT-SRH , Search , Problem

Product

SAP SuccessFactors HCM Suite 2605