SAP Knowledge Base Article - Public

3756789 - Performance History Card Error: The page isn't redirecting properly

Symptom

When attempting to open a performance form using the link from people profile, a new browser tab opens with an error:

The page isn’t redirecting properly
<browser> can’t connect to the server at <URL>
What can you do about it?
The site could be temporarily unavailable or too busy. Try again in a few moments.

Environment

SAP SuccessFactors Performance & Goals

Reproducing the Issue

  1. Log into SuccessFactors
  2. In the module picker, select My Employee File
  3. Select the Performance and Goals section
  4. In the Performance History card, locate a performance form and select the link to open it
  5. A new browser tab opens with the error

Cause

Keep last touched version upon Document completion is enabled on the performance form template

Resolution

This setting prevents users from seeing any updates to a form once it is completed, which explains why the links in the Performance History card do not open the forms.

To resolve this issue, navigate to Form Template Settings for the affected form and uncheck the box for the Keep last touched version upon Document completion setting.

See Also

Implementing and Managing Performance Management - Configuring Form Template Settings

Keywords

performance history, redirected too many times, page isn’t redirecting properly, this page isn’t working, open in new tab, performance form link, keep last touched version, completed forms access, performance management, card link, browser redirect error , KBA , LOD-SF-PM-POD , Home Page, Pods and Portlets, To Do List , Problem

Product

SAP SuccessFactors Performance & Goals all versions