Symptom
Not able to access the Review Customer Project app; message displayed "You can only review projects that are in execution and where forecast is set or projects that you are authorized to access."
Environment
SAP S/4HANA Cloud Public Edition
Reproducing the Issue
- Open the Plan Customer Projects app.
- Search for the affected project.
- Go to Related Apps.
- Select Review Customer Project.
- Observe the message displayed "You can only review projects that are in execution and where forecast is set or projects that you are authorized to access."
Cause
Required business catalog, space, and launchpad page assignments for the app are missing, even though the below business role are assigned.
SAP_BR_BILLING_CLERK
SAP_BR_INTERNAL_SALES_REP_PRSV
SAP_BR_PROJECT_MANAGER_PROF
SAP_BR_PROJ_BILLG_SPCLST
Resolution
- In Maintain Business Users (F1303), assign or confirm assignment of the business role SAP_BR_PROJECT_MANAGER_PROF to the user.
- Ensure the role includes business catalog SAP_PPM_BC_PROFNL_SRVC_PRJ_PC.
- Assign the space template SAP_BR_PROJECT_MANAGER_PROF to the role using app F4834.
- Using app F4512, assign page SAP_EPPM_PGT_PROJ_MANAGE_PROF_PC to the role and verify that tile F6869 exists on the page.
- Have the user log off and log back on to refresh authorizations.
- In Plan Customer Projects (F0719), set the project stage to “In Execution”.
- In Review Customer Projects (F1659), set the Forecast Month.
See Also
SAP Library - Project Control - Professional Services Projects
Keywords
review customer project, plan customer projects, cannot access app, authorization error, missing business catalog, SAP_PPM_BC_PROFNL_SRVC_PRJ_PC, SAP_BR_PROJECT_MANAGER_PROF, space assignment, launchpad page, SAP_EPPM_PGT_PROJ_MANAGE_PROF_PC, F1303, F4834, F4512, F0719, F1659, forecast month, in execution stage , KBA , CA-CPD-SS , S/4HANA Public Cloud – Professional Service Projects , How To
SAP Knowledge Base Article - Public