Symptom
In the app for creating golden tax documents, the customer name is displayed incorrectly.
Environment
SAP S/4HANA Cloud Public Edition
Reproducing the Issue
- Open the app to Create Golden Tax Documents.
- Select a relevant billing document or customer for document creation.
- Observe that the customer name shown in the app differs from the name maintained in customer data.
Cause
Standard behavior: the app displays the name from the international address version of the business partner.
Resolution
- Open the business partner master data.
- Navigate to the address overview tab and open the international address version.
- Update the name in the international address version to the correct value as required.
- Save the changes.
- Reopen the app to create golden tax documents and verify that the customer name displays as expected.
Please note that if there are multiple records in the address overview, the latest one with the valid period will be used.
Keywords
golden tax documents, incorrect customer name, international address version, business partner, China localization , KBA , FI-LOC-GTI-CN , China , Problem
Product
SAP S/4HANA Cloud Public Edition all versions
SAP Knowledge Base Article - Public