Symptom
The end user is not able to view and delete the attachments in the "Display Supplier Invoice - Advanced" app; attachments are not shown in “Attachment List” (via Services for Object) but are visible in “Manage Attachments”.
Environment
- Product: SAP S/4HANA Cloud Public Edition
- Fiori UI for Invoice Verification (Public Cloud)
Reproducing the Issue
- Open the “Display Supplier Invoice - Advanced” app.
- Enter a posted supplier invoice document number and fiscal year, then choose “Display Document”.
- From the top menu, select “Services for Object” and choose “Attachment List” — no attachments are displayed.
- Choose “Manage Attachments” — the attachments are visible, but deletion is not offered.
Cause
- Harmonized Document Management (HDM) is activated for the supplier invoice attachment object types (SSCUI 105346). If the attachment was uploaded with HDM activated, deletion is no longer possible.
Resolution
- Verify HDM activation in configuration: Manage Your Solution > Configure Your Solution > R&D / Engineering > Project Control and Product Development > Product Development Foundation > Activate HDM for Attachment Object Type (SSCUI 105346), and confirm that supplier invoice attachment object types are active.
- To view existing attachments, use “Manage Attachments” in the “Display Supplier Invoice - Advanced” app.
- Be aware: If an attachment was uploaded while HDM was activated, it cannot be deleted.
See Also
Keywords
display supplier invoice advanced, services for object, attachment list, manage attachments, cannot view attachments, cannot delete attachments, posted invoice, supplier invoice attachments, hdm, harmonized document management, sscui 105346, invoice attachments visibility, fiori app attachments , KBA , MM-FIO-IV-2CL , Fiori UI for Invoice Verification (Public Cloud) , Problem
Product
SAP S/4HANA Cloud Public Edition all versions
SAP Knowledge Base Article - Public