Symptom
When replicating employees to SAP S/4HANA Cloud Public Edition, the error message "Worker with worker id * not found" is generated.
Environment
SAP S/4HANA Cloud Public Edition
Cause
The error is being triggered since the Workforce Provisioning Channel is maintained as IDM in the SSCUI Config. This means that the Business User & Basic Worker needs to created from IDM Integration before the Employee can be replicated/updated from HCM Channels.
Resolution
- In the Development system, open the Implementation Activities app (or CBC).
- Navigate to General Business Data > Employees and Service Agents > Employees > Settings for Worker Creation > Define Workforce Management Scenario (SSCUI ID 106757). Alternatively, search in CBC for configuration activity "Define Workforce Management Scenario" (SSCUI ID 106757).
- Change Provisioning Channel from “Manage worker using IdM integration” to “Manage worker using HCM integration.”
- Transport the change to the Test system (export customizing transport from Development and import the collection into Test), then initiate an initial load from the HCM channel again.
- If HCM integration is not required in the Development system, change the Provisioning Channel back to “Manage worker using IdM integration.”
See Also
Keywords
employee replication, business partner not created, hcm channels, mdi, workforce management scenario, define workforce management scenario, 106757, provisioning channel, idm integration, hcm integration, replication without error, s/4hana cloud, employee to bp, workforce provisioning, integration settings , KBA , CA-WFD-INT , S/4HANA Cloud Workforce Domain Integration , Problem
SAP Knowledge Base Article - Public